[PHONE API] Goole

Incident Report for Trustfull

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 18:03 CEST

Investigating

We are currently investigating this issue.
Posted Jun 17, 2025 - 18:03 CEST
This incident affects: Phone API (Google).