EMAIL API: Ebay
Incident Report for Trustfull
Investigating
We are currently investigating this issue.
Posted Oct 22, 2024 - 12:00 CEST
Identified
We are currently investigating this issue.
Posted Sep 23, 2024 - 16:54 CEST
This incident affects: Email API (eBay).